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Preface

Important:  Notice to customers:
All documentation becomes dated, and this manual is no exception. Microchip tools and documentation
are constantly evolving to meet customer needs, so some actual dialogs and/or tool descriptions may differ
from those in this document. Refer to our website (www.microchip.com) to obtain the latest documentation
available.

Documents are identified with a “DS” number. This number is located on the bottom of each page, in
front of the page number. The numbering convention for the DS number is “DSXXXXXXXXA”, where
“XXXXXXXX” is the document number and “A” is the revision level of the document.

Introduction
This document describes how to install, configure and use the MPLAB® Code Configurator (MCC) software tool
during or before starting the development process of an embedded software application designed with PIC®

microcontrollers.

Recommended Reading
This user's guide refers to MCC operation only. Other applicable documents are listed below. The following Microchip
documents are available and recommended as supplemental reference resources:

• Release Notes for the MPLAB Code Configurator
• MPLAB X IDE User’s Guide
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1. Introduction
The MPLAB® Code Configurator (MCC) generates driver code using a Graphical User Interface (GUI). The
generated drivers control the peripherals on PIC® microcontrollers. The GUI provides an easy means for setting
up the configuration of the peripherals. MCC is a plugin for the MPLAB® X IDE and MPLAB® Xpress.

Additionally, the MCC is used to configure and generate libraries, allowing code generation and configuration for
software libraries and external components.

The generated drivers or libraries can be used in any Microchip PIC or AVR® device application program. MCC
requires creating or opening an already existing project in the MPLAB X IDE or MPLAB Xpress before launching
the MCC plugin. This is necessary as the MCC needs to know the device used in the project, to have access to
device-specific information like registers, bits, configurations, and to set up the MCC GUI.

The MCC generates source and header files based on selections made in the GUI. The generated files are added to
the active project of MPLAB X IDE or MPLAB Xpress.

 MPLAB® Code Configurator v3.xx User...
Introduction
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2. Installation
The MPLAB Code Configurator can be installed in two ways: via the Microchip Plugins Update Center or from the
Microchip website. The following chapters describe these procedures and also the MCC update process.

2.1 Installing MPLAB® Code Configurator from the Microchip Plugins Update Center
By default, MCC is not installed together with the MPLAB® X IDE and must be downloaded separately and installed.
One way to do so is via the Microchip Plugins Update Center:

1. In the MPLAB X IDE, go to Tools -> Plugins.
2. Go to the Available Plugins tab.
3. Select MPLAB Code Configurator and click the Install button. See figure below.
4. The Plugin installer opens. Click Next and check the Terms and Agreements. After this step, the Plugin

installer begins downloading the MCC plugin.
5. When the MCC plugin download is complete, MPLAB X IDE will ask to be restarted. Upon restart, the plugin is

installed.
6. MCC can now be opened on a new or already existing MPLAB X IDE project. See Section 4.1 “Setting Up

MPLAB X IDE and Launching MCC.“

Figure 2-1. Installing MPLAB® Code Configurator

2.2 Installing MPLAB® Code Configurator from the Microchip Website
The MCC plugin can also be downloaded from the Microchip website by typing the address www.microchip.com/mcc
in a web browser, selecting the Current Download tab, and downloading the Current Version .zip file. See Figure
2-2.

 MPLAB® Code Configurator v3.xx User...
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Figure 2-2. Downloading MCC from the Microchip Website

Once downloaded, extract the archive which contains the MCC plugin to a preferred location. To install the
downloaded plugin, complete the following instructions:

1. Open MPLAB X IDE.
2. Go to Tools -> Plugins.
3. Select the Downloaded tab, and click on the Add Plugins... button.
4. Navigate to the folder where the downloaded .zip file was extracted and select the MCC plugin. It may have

a .nbm file extension.
5. Click on the Install button. MPLAB X IDE will ask to be restarted. Upon restart, the plugin is installed. See

figure below.
6. MCC can now be opened on a new or already existing MPLAB X IDE project. See Section 4.1 “Setting Up

MPLAB X IDE and Launching MCC.”

Figure 2-3. Installing MCC from Downloaded File

2.3 Updating MPLAB® Code Configurator
When an MCC version newer than the one installed is available, the MPLAB X IDE will display a notification in the
bottom right corner of the IDE window. By clicking on it, the plugin update wizard is launched. In the wizard, click on
the Install button, and the software will download and install the new MCC plugin version. See figure below.

 MPLAB® Code Configurator v3.xx User...
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Figure 2-4. Updating MPLAB® Code Configurator

2.4 Older MPLAB® Code Configurator Versions
Older MCC versions are available at the same www.microchip.com/mcc address, under the Archive Download tab.

 MPLAB® Code Configurator v3.xx User...
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3. MCC Plugin Options
Several aspects of the operation of the MCC can be managed by using the “Options” panel (see figure below), which
can be invoked by clicking Tools → Options → Plugins → MPLAB Code Configurator in the menu bar of the
MPLAB X IDE.

Figure 3-1. The MCC Option Panel

The MCC Options panel offers the following controls:

• File Handling
• Generated Line Endings
• Editor Behavior

3.1 File Handling
1. Remove unused files from the project: Enabling this option tells the MCC to remove .c and .h files from

modules which were removed from the MCC configuration between the subsequent generation procedures.
This option ensures that the files included in the project (and thus in the compilation) are only those which are
strictly necessary. However, this will not delete the files from the disk.

2. Delete unused files from the disk: This option gets enabled only when selecting “Remove unused files from
the project,” which performs the additional task of deleting unused files from the disk. Once a file is deleted, it
cannot be recovered.

3.2 MCC Line Endings
Specify the type of line endings to use in the files generated by MCC. The default is DOS (<CR><LF>). Unix line
endings (<LF>) may be specified.

 MPLAB® Code Configurator v3.xx User...
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3.3 Editor Behavior
1. Always ask before removing a module: Enabling this control enables the “Are you sure?” dialog box which

appears while disabling or removing an enabled module.
2. Always ask before removing a pin: Enabling this control enables the “Are you sure?” dialog box which

appears while deallocating or removing a pin from a peripheral.

3.4 Installing an MPLAB® Code Configurator Library
The MPLAB Code Configurator provides a peripheral or software library installation feature. This feature can be used
to add MCC-compatible libraries. There are several libraries for various applications the user can choose from on
the http://www.microchip.com/mcc webpage. An MCC Library file may have a .jar or a .mc3lib file extension.
Once this file is downloaded, open the MPLAB X IDE, and in the above menu go to Tools → Options → Plugins →
MPLAB Code Configurator 3.x, click on the Install Library button and select the .jar file via the Open File dialog
box. The Versions window will now list the newly added library as installed.

If there are multiple versions of a library, the newly installed one will not be the loaded one. To load a particular
version of a library, right-click on it and select “Mark for Load,” which will then highlight the user’s choice. If the user
has multiple libraries with multiple versions in each, one from each can be highlighted before loading them. See
Section 3.3. “Versions Area” for more details about switching library versions.

Removing a library is done using the Remove Library button. The File selection dialogue window will open the
Library folder. Select the library to remove and click on the Remove button on the File selection dialogue. The library
can be verified if it is no longer present on the computer by going to the Versions operating area - the removed library
version is not present on the computer anymore. It may be present as available for download.

If a library currently in use is attempted to be removed (green tick in the Versions area), MCC will not allow this
to happen. To remove that library version, switch to another version, go back to the Options window and press the
Remove Library button again for the library version to delete.

3.5 Installing an MPLAB® Code Configurator Core
The MPLAB Code Configurator provides a core switching feature. This feature works simultaneously on various
projects with different core versions without uninstalling or reinstalling the plugin. To install a new core, download first
the new core from the Microchip MCC webpage (http://www.microchip.com/mcc). This file may have a .mc3core file
extension. Once this file is downloaded, open the MPLAB X IDE and in the above menu go to Tools → Options →
Plugins → MPLAB Code Configurator 3.x, click on the Install Core button and select the .mc3core file via the
Open File dialog box. The Versions window will now list the fresh core installation.

To switch to another core version, either double click on it, or right-click on it and select “Switch Core Version.” The
Versions window will now refresh the core selection with the user’s choice. The core installations can always be
checked by opening the Core folder, from Tools → Options → Plugins → MPLAB Code Configurator 3.x path.
Refer to Section 3.4. “Versions Area” for more details about core switching.

Removing a core version is done from the Remove Core button. The Folder selection dialogue window will open the
"Core" folder. Select the core version to remove and click on the Remove button on the Folder selection dialogue.
The core version can be verified it is no longer present on the computer anymore by going to the Versions operating
area - the core version removed is not present on the computer anymore. It may be present as available for
download.

If a core version currently in use is attempted to be removed (green tick in the Versions area), MCC will not allow this
to happen. To remove that core version, switch to another core version, go back to the Options window and press the
Remove Core button again for the core version to delete.

 MPLAB® Code Configurator v3.xx User...
MCC Plugin Options

© 2022 Microchip Technology Inc.
and its subsidiaries

 User Guide DS40001829F-page 9

http://www.microchip.com/mcc
http://www.microchip.com/mcc


4. Generating MCC Code
Now that MCC has been installed and its main operating areas are learned, it is time to set up MCC according to the
user’s needs and begin configuring the project. The following subsections cover basic MCC operation and the code
generation process.

4.1 Setting Up MPLAB® X IDE and Launching MCC
To generate drivers using the MCC in MPLAB X IDE, follow these steps:

1. Create a new MPLAB X IDE project or open an existing project (see figure below).
2. If multiple projects are open in MPLAB X IDE, set one as the main (active) project by selecting “Set as Main

Project” in the MPLAB X IDE. For the active project, the MCC automatically includes the generated driver files.
3. Open the MCC plugin tool. In the menu bar of the MPLAB X IDE, go to Tools → Embedded → MPLAB Code

Configurator 3.x: Open/Close. Or click on the MCC icon in the MPLAB X IDE toolbar.

Note:  For MAC users, the “Embedded” selection will be under the Preferences menu. This launches the MCC GUI.

Figure 4-1. Opening the MCC in MPLAB® X IDE

When opening MCC for the first time on an MPLAB X project, the configuration saving dialog will be displayed asking
for a name and saving path for the MCC configuration file attached to the project. The MCC configuration is also
saved to the disk when the Generate button is pressed or if the MPLAB X IDE Save button is clicked. An existing

 MPLAB® Code Configurator v3.xx User...
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MCC configuration file can be loaded by double-clicking on the desired .mc3 file in the Important Files section of the
MPLAB X IDE project.

4.2 Generating Code
When the MCC Generate button is pressed in the Project Resources window, the listed actions are performed by
MCC. Details of the code generation are shown in the MCC Output tab. See 6.4.2.  The MPLAB® Code Configurator
- Output Tab.

1. The MCC configuration file is saved.
2. MCC generates code for the peripheral or library module if the module’s configuration has changed since the

last time MCC generated code for that module.

Note:  All modules can be forced to be generated by MCC by right-clicking in the Project Resources section from the
6.1.  Resource Management Area and selecting “Force Update,” before clicking on the Generate button.

If MCC attempts to regenerate a file on the disk that has been modified outside of MCC, the Merge [MCC] window
is displayed. Use the Merge [MCC] window to select whether to keep the modified file (default action) or replace the
modified content with the content generated by MCC.

The Merge [MCC] window is discussed in Section 4.3.2 “The Merge [MCC] Window.”

4.2.1 Saving and Loading the MCC Configuration
Saving and loading the MCC configuration is integrated into the MPLAB X IDE Save and Load functions. The MCC
configuration is saved whenever the Generate button is pressed. The MCC configuration can also be saved by
clicking on the MPLAB X IDE Save tool or selecting Save from the File menu.

The MCC configuration file is included in the MPLAB X IDE project under the Important Files folder. The
configuration file uses the extension .mc3. Double-clicking on the MCC configuration file will cause that MCC
configuration to be loaded.

4.2.2 The Merge [MCC] Window
If any of the files generated by the MCC have been edited outside of MCC and saved to the disk, then the Merge
[MCC] window appears in the Composer Area. Use the Merge [MCC] window to select whether to keep the edits or
replace them with the newly generated MCC code.

Note:  The user’s edits will never be overwritten by the MCC-generated code, except explicit action in the Merge
[MCC] window.

When changes have been made to both a generated file and the corresponding MCC UI within the Composer Area,
the Merge [MCC] window shown in Figure 4-2 will be displayed. The Merge [MCC] window allows resolving the
conflicts between the newly generated file and the edits made to the file.

When the newly generated MCC content has been accepted, MCC makes the changes to the file. To the MPLAB X
IDE, these changes are the same as if they were typed in the new content. The normal MPLAB X IDE edit undo can
be used in the MCC Merge operation.
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Figure 4-2. Merge [MCC] Window - File List

A list of all the files that need to be merged is shown at the top of the Merge [MCC] window. Each file in the list must
be selected, in turn, to ensure that all of the newly generated code is incorporated into the project.

At the top of the Merge [MCC] window, in the center margin, there is an arrow, as shown in Figure 4-3. Clicking on
the arrow will replace all the edits in the current file with the MCC updated code that the MCC has just generated.
The numbers above the arrow indicate the current difference and the total number of differences.

Figure 4-3. Merge [MCC] Window - Replacing All Edits with MCC Generated Code

The individual lines of MCC Updated Code can be selected to replace the edited code. As shown in Figure 4-4,
clicking on the arrows in the right margin of the left window will copy the MCC Updated Code to the generated driver
file. Once the changes are accepted, the Merge mechanism will remove the highlighted file and highlight the next file

 MPLAB® Code Configurator v3.xx User...
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on the list. A warning will be generated if the Merge mechanism is closed before all the changes are accepted to
ensure all updates are completed.

Figure 4-4. Merge [MCC] Window - Replacing Single Changes with MCC Generated Code

Notes: 
1. Remember to merge the code for every file shown in the file list of the Merge [MCC] window.
2. Be sure to save all the changed files from the Merge process.

 MPLAB® Code Configurator v3.xx User...
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5. MCC Content Manager
The MCC Content Manager (CMT) allows users to select specific versions of the component modules and libraries to
be used for their MCC projects. Refer to the MCC Content Manager Reference for more information.

The MCC Melody Content Manager, supports content management and versioning at a component level.
• This means that component modules of a project can be updated on its own, separate from the other modules.

For example, if you have a working project, except for a bug on the ADC driver. Now, rather than needing to
update all the other drivers in your system, like the UART and Timers, you will be able to update just the ADC.

• This component level content versioning granularity will be especially useful in the latter stages of your project
development, as you near production. At this stage, when almost everything is working perfectly, one may want
to change one modules one needs to, due to either bugs or needed features.

Figure 5-1. Opening the MCC Content Manager Reference, MCC User Guide
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6. MCC Classic
MCC Classic is the original plugin and user interface for the MPLAB® Code Configurator. It consists of six main
operating areas, as shown in Figure 3-1.

1. Resource Management Area: Contains the Project Resources and all the available/device resources. See
6.1.  Resource Management Area section for more details.

2. Versions Area: Shows the complete list of MCC Cores, Peripheral Libraries, and Software Libraries which
can be used with the selected device. Some of these are installed together with MCC. Others are available
for download. Depending on the selected device, some core and library versions are interchangeable. See
6.2.  Versions Area section for more details.

3. Pin Manager Package View Area: Graphic interface for pin selection and configuration. Bidirectional
operation with the Pin Manager Grid View. See 6.3.  Pin Manager Package View Area section for more
details.

4. Pin Manager Grid View Area: Contains three inner tabs: Notifications (errors, warnings and general
information regarding the current selections), Pin Manager - Grid View (a table version of the Pin Module
Package View) and Output (MCC Log & MPLAB X IDE Log). See 6.4.  Pin Manager Grid View Area chapter
for more details.

5. Composer Area: This is the main area in which a peripheral or library driver can be configured. It displays the
possible configurations of the peripheral/library. See 6.5.  The Composer Area chapter for more details.

Figure 6-1. MCC Operating Areas

Note:  All operating areas are dockable. Each can be dragged and dropped into another position, even out of the
MPLAB X IDE main window (closing the IDE, however, will close all MCC windows, including those moved outside
the IDE).

6.1 Resource Management Area
The Resource Management Area comes with two separate views: the tree view and the flat view. Both provide
access to the complete list of software/peripheral components and the selected components for the current project
configuration. For more details on each view, refer to 6.1.1.  Resource Management Area - Tree View and
6.1.2.  Resource Management Area - Flat View sections.

The Project Resources section is common to both views of the Resource Management Area. This section displays
the list of on-chip peripherals, external components, and libraries that have been selected for the current MCC
project. The information specific to each of the two views regarding this section is available in 6.1.1.  Resource
Management Area - Tree View and 6.1.2.  Resource Management Area - Flat View sections.
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There system modules are always available in the Project Resources section. These modules cannot be removed.
The modules are:

1. Interrupt Module: Configures the interrupts for the device.
2. Pin Module: Configures the pins for the device.
3. System Module: Configures the system clock, Configuration bits, and other device-level functions for the

device.

A module in the Project Resources window can be removed from the project by clicking the  or  button to
the right of the module name in the Project Resources section. The module will be removed from the MPLAB X IDE
project. When a module is removed from the Project Resources, all the unsaved configuration information for that
module is lost.

At the top of the Project Resources section, there are three buttons:

• Generate: Once the project configuration has been completed, clicking this button will trigger the code
generation process for that specific configuration.

• Import: An MCC configuration file (.mc3 extension) can be imported into the current project. If the selected
configuration has been created for a device other than the one used in the current project, an alert message
pops up offering the possibility of an experimental configuration migration. Once a configuration file is selected,
MCC loads and configures all modules detailed in the selected configuration file. If there is a match between
a module from the configuration and a module already loaded in the current project, the settings for the
loaded module are overwritten with the ones from the imported configuration file. This is useful for the partial
configurations created manually or provided by the Export functionality detailed below. In the case of importing
a configuration created for a different device than the one used in the current project, an alert message pops
up offering the possibility of an experimental configuration migration or canceling the import process (See Figure
6-2). During device migration, the import process might fail due to hardware mismatches between the two
devices. In this case, a backup configuration file is created and saved in the project folder. (See Section 6 “MCC
Device Migration”).
Figure 6-2. Importing a Configuration Created for a Different Device

• Export: Allows the export of partial configurations. Any loaded module in the Project Resources, except System
modules, can be selected for a partial configuration by right-clicking on the module and selecting "Mark for
config export" (see figure below for more details). All modules marked for export are shown in bold. Clicking
the Export button creates an MCC configuration consisting only of the modules marked for export. To remove
the selection, use "Unmark from config export" for a specific module or "Unmark all for config export" for all
modules/components selected for export.
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Figure 6-3. The Context Menu of the Project Resources Area

Besides the partial configuration export mechanism, the Context menu of the Project Resources Area (displayed
above) includes several other operations on the loaded components or modules, such as:

• Force Update: Regenerates code for all the selected modules/components, even if no modifications were
added to their configuration. See Section 4.3 “Generating Code”.

• Refresh [module_name] Windows: Reopens the configuration window of the selected module if that window
has been closed previously. If the Context menu is invoked by right-clicking under the Resources list with no
module/component selected, this option will be available as Refresh Module Windows, and its effect will be
global. All previously closed MCC windows will be reopened.

• [module_name] Help: Opens the help content for the user interface of the selected module/component, if
available.

6.1.1 Resource Management Area - Tree View
This view is further split into the Projects Resources section (detailed at the beginning of 6.1.  Resource Management
Area chapter) and the Device Resources section. See Figure 6-4.

Both sections in the Tree View can also be navigated and handled by using the following keys:

• Up and down arrow keys: For moving up and down in the tree, respectively.
• Right arrow key: For expanding a node.
• Left arrow key: For collapsing a node.

 MPLAB® Code Configurator v3.xx User...
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Figure 6-4. Resource Management Area - Tree View

6.1.1.1 The Project Resources section
This section displays the peripherals, libraries or external components selected for the current project. The selection
is done via the Device Resources section. The System Module, Pin Module, and Interrupt Module are selected by
default. The configuration for each of the selected modules is done through the Composer Area. The peripheral and
libraries are added to the project by selecting them from the Device Resources section. To add a peripheral or library
to the Project Resources section, double-click on its name in the Device Resources section. The configuration can
then be done via the corresponding GUI in the Composer Area. A module in the Project Resources window can be

removed from the project by clicking the  button to the right of the module name in the Project Resources section.
The module will be removed from the MPLAB X IDE project. When a module is removed from the Project Resources,
all of the unsaved configuration information for that module is lost.

6.1.1.2 The Device Resources section
The Device Resources section (see figure below) lists the data sheet, external components, and libraries available
for the device configured in the MPLAB X IDE project, based on the loaded libraries in the Versions area. When
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the name of a peripheral or library is double-clicked, it is moved from the Device Resources area to the Project
Resources area, simultaneously invoking the Pin Manager with all associated I/O pins.

Note:  The Documents section of the Device Resources area provides a link to the data sheet of the selected device
on www.microchip.com.

Right-clicking on a module or component in this tree shows the Device Resources context menu through which the
help content of the selected module can be invoked. The Device Resources list can be filtered via the top combo box
(see figure below). The available filters are:

• all supported and tested modules
• all supported modules (including untested ones)
• all modules (including unsupported ones)

Figure 6-5. Resource Filtering in Device Resources - Tree View

6.1.2 Resource Management Area - Flat View
This view is further split into the Projects Resources section (detailed at the beginning of 6.1.  Resource Management
Area chapter) and the available resources section. See figure below.
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Figure 6-6. Resource Management Area - Flat View

6.1.2.1 The Project Resources section
This section displays the peripherals, libraries or external components selected for the current project. Selection
is done via the Available Resources window, which can be accessed from the Available Resources section (see
6.1.2.2.  The Available Resources section). The Project Resources section in the Flat View is similar to the Project
Resources in the Tree View (see 6.1.1.1.  The Project Resources section). A module in the Project Resources

section in the Flat View can be removed from the project by clicking the  button to the right of the module name.
The module will be removed from the MPLAB X IDE project. When a module is removed from the Project Resources,

all the unsaved configuration information for that module is lost. Next to the  button, the  button offers insight
into a specifically selected module. The same module information can be retrieved from the [module_name] Help
option in the Project Resources context menu (see Figure 6-3).

6.1.2.2 The Available Resources section
This section contains two buttons:

• Show [device_name] Product Page: Opens the product page from the Microchip website in the default browser.
• Show Available Resources: Opens, or brings into focus, the Available Resources window in the Composer

Area. See Figure 6-7 below.
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Figure 6-7. Available Resources Window

The Available Resources window in the Composer Area represents a table of all software/peripheral components
available for the selected device with search and filter capabilities. Each module in this table is indexed by three
attributes: Module name, module type, and the library containing the module. These attributes are mapped on each
table column as follows:

• Module: Displays the module icon, module name, link to module help (via the  button and module selection

(via the  button). When a module is selected, it is added to the Project Resources section under the
Resources Management area. A module can be searched by its name using the text field in the Module column
header. The Available Resources table can be sorted alphabetically by module name when clicking on the arrow
in the column header.

• Type: Displays the type of functionality provided by each module (i.e., Peripheral, Interface, Mixed-Signal).
The table entries can be filtered by module type using the text field in the Type column header. The Available
Resources table can be sorted alphabetically by module type when clicking on the arrow in the column header.

• Library: Shows the name of the library containing a certain module. The table entries can be filtered using
the Available Libraries drop-down in the Library column header. When using the Available Libraries drop-down,
the table contents can be filtered to include modules from one or several libraries. Also, it is possible to show
modules from all libraries (using the All Libraries option) or clear the whole table (using the Clear All Libraries
option). The Available Resources table can be sorted alphabetically by library name when clicking on the arrow
in the column header. Depending on the selected device and the selected filters, the Available Resources
window might show several modules with the same name but coming from different libraries. For example, in the
case detailed in Figure 6-7, there are two ADC modules shown: One from the peripheral library and the other
from the MikroElektronika Clicks library. Generally, modules bearing the same name are mutually exclusive.
After a module selection, no other module with the same name can be selected. The module selection button
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becomes grayed out, and clicking on it will yield a pop-up message saying that the operation cannot be
completed (see Figure 6-8).

Figure 6-8. Module Selection Disabled

6.2 Versions Area
The Versions Area provides information about the versions of each MCC Core, Peripheral Library, Software Library,
or other component installed on the local computer. Over time, multiple versions of the libraries may be available.
MCC can be configured to use a specific version of a Library for the current MCC project.

Loaded versions are displayed with a green checkmark, compatible but not loaded versions are shown with a
grey circle, and available versions which are unsupported by the selected core version are displayed with a circle
backslash symbol (see Figure 6-9).

The MCC Core versions can be switched by right-clicking on an available core version and selecting "Switch core
version" from the Context menu. Library versions can be loaded by right-clicking on a version of a component/module
and selecting "Mark For Load." This action triggers the Load Selected Library button to appear at the top of the
Versions Area. By clicking the button, all library versions which have been marked are loaded into MCC. Multiple
selection are allowed; several components can be loaded at the same time. Only one version for each module/
component is allowed to be loaded at a time.

If the component is already installed on the local computer, the absolute path to the corresponding .jar file is
displayed next to the component's name. If the component has not yet been installed, the "Available for download"
message is displayed instead. Selecting an uninstalled component for load and then pressing the Load Selected
Libraries button will download the corresponding .jar file from a Microchip server and will subsequently load it in
MCC, provided that the selected version is compatible with the loaded core version.
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Figure 6-9. Versions Area

Besides the Versions Area, a core or a library can also be loaded via the MPLABX IDE menu in Tools → Options →
Plugins → MPLAB Code Configurator (see Section 3.8 “MCC Options”).

Note:  All MCC libraries are published via the Microchip website: www.microchip.com/mcc.

6.3 Pin Manager Package View Area
The following color combinations are associated with the pins in Graphical or Table View:

1. Gray colored pin: The pin is not usable in the selected configuration, and no enabled module that has any
functionality on that pin. There are also grayed-out locks on a white background that indicate pins locked out
by selected system functions.

2. Blue colored pin: Pins that are available to be allocated to a module.
3. Green colored pin (with a lock): The pin has been allocated and selected for a module. The name displayed

against the pin is either the pin name of the module’s context or a custom name entered.
4. Green colored pin (with chain link): The pin is shared between multiple functions.
5. Yellow colored pin: A possible alternate pin for an already allocated pin function.
6. Grayed out locks on a white background: Pins locked out by selected system functions.

The graphical Pin Manager can be zoomed in and out to adjust its visibility. This can be done by scrolling the mouse
wheel when the mouse is over the Package View. Zooming can also be achieved by the “+” and “-” keys on the
keyboard (useful if the mouse is not available).

By right-clicking on a specific pin, all available pin functions are listed for selection. A snapshot of the package view
configuration can be saved in PNG format by right-clicking on the package and selecting "Export Image."
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Figure 6-10. Package View Area

6.4 Pin Manager Grid View Area
This area contains three inner tabs: Pin Manager Grid View, Output and Notifications.

6.4.1 The Pin Manager Grid View
In the Pin Manager Grid View, the device package can be selected from a drop-down list. The package selection is
on the upper left side of the Pin Manager Table View. In the figure below, the drop-down list shows that the QFN64
package has been selected. The selected package will be displayed in the Package View. The pin numbers in the
Table View will also show the pin numbers for the selected package.
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Figure 6-11. The Grid View Area

The three leftmost columns in the Table View indicate the module’s name, functionality name, and direction,
respectively.

The Table View allows to:

• Expand/collapse rows and ports (Figure 6-12)
• Hide and show ports and rows (Figure 6-13 and Figure 6-14)
• Show only the pins that are configured (Isolate) (Figure 6-15)

Figure 6-12. Collapsing Ports and Rows

Figure 6-13. Hiding Ports and Rows
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Figure 6-14. Restoring Ports and Rows (Show All)

Figure 6-15. Isolating the Selected Pins

6.4.2 The MPLAB® Code Configurator - Output Tab
This tab displays the MCC operation results (see figure below). The MPLAB X IDE Log is also displayed under the
Output tab when specifically opened from the View -> IDE Log menu.

Figure 6-16. The MPLAB® Code Configurator - Output Tab

6.4.3 The Notifications Tab
During the configuration process, several messages may be displayed in the Notifications tab (Figure 3-15) to
help identify issues or simply to make sure a specific setting is configured as intended. These are indexed in the
Notifications tab by:

1. Category: Identifies the notification as an alert or information that the module depends on another module.
2. Module Name: Is the name of the module that generated the notification.
3. Type: Indicates the severity of the notification.

There are four types of notifications:

• SEVERE: Either the code generation or the compilation process will be faulty with the current configuration.
• WARNING: The code will be generated according to the settings made. It may compile, but it might also fail to

function as intended.
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• HINT: This provides information to assist in the successful configuration of the module. The module and the
MCC can still be used. An action might be required.

• INFO: Information only, no action is required.

These can be filtered out using the Type combo box. If there are any WARNING or SEVERE type messages
present in the Notifications tab when the Generate button is clicked, a message box displays, giving the option
of reconfiguration to eliminate the possible errors in the current settings. This action can be skipped, assuming the
notifications have been reviewed and taken into consideration.

Figure 6-17. The Notifications Tab

Note:  The notification type may change as the MCC configuration changes. For example, WARNING might indicate
that a module requires another module to be added to the project to operate correctly. After adding the module, the
notification type would change to INFO.

6.5 The Composer Area
When a peripheral, library or other external component is selected from the Project Resources Area, its
corresponding configuration GUI is displayed in the Composer Area. The Composer Area (Figure 6-18) is where
peripherals and libraries are configured based on the application’s requirements.

 MPLAB® Code Configurator v3.xx User...
MCC Classic

© 2022 Microchip Technology Inc.
and its subsidiaries

 User Guide DS40001829F-page 27



6.5.1 The Easy Setup Tab
Figure 6-18. The Easy Setup Tab of the PIC16F1947 EUSART Module

The EUSART Easy Setup tab in the Composer Area allows configuring various EUSART parameters related to
transmission and reception operations.

6.5.2 The Registers Tab
In addition to the Easy Setup tab in the module’s Composer, MCC also provides a Registers tab (Figure 6-19). The
Registers tab provides direct access to configure the module’s registers and settings, providing unrestricted access
to the configuration of the module.

Any module configuration done using the Easy Setup tab will be reflected in the values displayed in the Registers
tab. Likewise, changes performed in the Registers tab reflecteds in the values in the Easy Setup tab.
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Figure 6-19. The Register View

6.5.3 The Pin Module Tab
For any pin which has been configured in the Pin Manager Table View, additional configuration of that pin can be
done using the Pin Module View in the Composer Area. To display the Pin Module View, click on the Pin Module tab
in the Project Resources Area (see Figure 6-20.)

The following settings are available in this tab (depending on the selected pin).
• Pin Name: The port pin name
• Module: The name of the module containing the function of the pin.
• Function: Module-specific functionality available on the pin. A pin may have one or more selectable functions.

Typically, a pin may be configured to have several functions at the same time if it s also configured as an input
(Output column unchecked). Only one function per each pin can be matched with an output direction. Refer to
the device data sheet for more details.

• Custom Name: A useful pin alias which can be used in the generated code. A set of macros are made available
in the Pin Module generated code for each selected pin in MCC.
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• Start High: Sets the pin to a high/low logic level at device initialization.
• Analog: Configures the pin as analog or digital.
• Output: Sets the pin direction of the pin.
• WPU: Enables the weak pull-up resistor on the pin.
• WPD: Enables the weak pull-down resistor on the pin.
• OD: Enables the open-drain capability on the pin.
• IOC: Configures the interrupt-on-change capability of the pin.

Note:  Some of the settings detailed above may be missing on some pins or from the device completely. Refer to the
pins configuration section in the device data sheet.

Figure 6-20. The Pin Module Tab

6.6 Generated Sources and Header Files
The generated drivers will be included in the active MPLAB X IDE project, as shown in the figure below.
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Figure 6-21. Generated Source and Header Files

1. The mcc.h and mcc.c files include the definitions of Configuration bits and the ‘OSCILLATOR_initializer’
function. These definitions are based on the settings made for the System module in the Composer. Also
included is the ‘SYSTEM_initializer’ function, which can be called in the application program to call all the
other default initializers (the ones marked in the GUI by sprocket symbol).

2. The pin_manager.h and pin_manager.c files include the Pin Manager initializer functions based on the
configurations made in the Pin Manager GUI.

3. The interrupt_manager.h and interrupt_manager.c files are optional files generated only when
peripheral interrupts are enabled, and they include interrupt initializer functions.

4. The .c and .h are module-specific files and include each module’s peripheral\library configuration functions.
5. The main.c file is generated even if a main.c already exists in the project. The user can review the code in the

generated main.c file and merge the changes to the existing main.c file if required. The main.c file generated
by the MCC may include commented-out code lines to enable interrupts. Remove the comments from the
appropriate lines if the application requires interrupts to be enabled when it starts.
Note:  When using a main.c not generated by the MCC, the following lines need to be added to the main.c
file‘#include "mcc_generated_files/mcc.h";’ and ‘SYSTEM_Initializer()’.

The functions provided in these MCC-generated files can be called from the user application code, as required. The
MPLAB X IDE provides auto-completion assistance of all of the MCC-generated content. While editing source code in
the project, start typing in an MCC API or MCC variable name, and press <CTRL+ Space>. The MPLAB X IDE will
show a list of options to complete the entry.
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6.7 MCC Device Migration
Using an MCC configuration created for one device on a different device is called MCC device migration.

Note:  MCC device migration is not supported in MCC.

It is possible that attempting to use an MCC configuration on a device other than the one for which it was created
might appear not to fail. It is entirely the user's responsibility to determine if the MCC code generated as the result of
device migration is suitable for use in their application.

Unintended MCC device migration may occur if the selected device in the MPLAB X IDE project is changed after
MCC has been configured for that project. Copying an MCC configuration file (*.mc3) to another MPLAB X IDE
project may also cause MCC device migration or other unintended operations.
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7. MCC Melody
MCC Melody is a new flavor of MCC that provides Libraries, Drivers, Peripheral Libraries (PLIB), and Hardware
Initializers (HWI) for the development of embedded software for Microchip PIC® and AVR® Microcontrollers (MCUs)
and dsPIC® Digital Signal Controllers (DSCs).

Its key features include:
1. A structured relationship manager (MCC Builder) which provides a clear visualization of a component's related

dependencies and context in your project.
2. An implementation that can enable components available to be configured in the new online development

ecosystem, i.e., in MPLAB Xpress IDE.
3. A content manager which allows more granular, component-level versioning and selection.

For more information, go to the MCC Melody Technical Reference.
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8. MCC Harmony
MPLAB Harmony 3 provides a Chip Support Package (CSP), core hardware abstraction libraries, extensive
middleware, and a graphical configuration tool for the development of C language embedded software for Microchip
32-bit microcontrollers and microprocessors. For more information, refer to the Microchip MPLAB Harmony Github
Page.
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The Microchip Website
Microchip provides online support via our website at www.microchip.com/. This website is used to make files and
information easily available to customers. Some of the content available includes:

• Product Support – Data sheets and errata, application notes and sample programs, design resources, user’s
guides and hardware support documents, latest software releases and archived software

• General Technical Support – Frequently Asked Questions (FAQs), technical support requests, online
discussion groups, Microchip design partner program member listing

• Business of Microchip – Product selector and ordering guides, latest Microchip press releases, listing of
seminars and events, listings of Microchip sales offices, distributors and factory representatives

Product Change Notification Service
Microchip’s product change notification service helps keep customers current on Microchip products. Subscribers will
receive email notification whenever there are changes, updates, revisions or errata related to a specified product
family or development tool of interest.

To register, go to www.microchip.com/pcn and follow the registration instructions.

Customer Support
Users of Microchip products can receive assistance through several channels:

• Distributor or Representative
• Local Sales Office
• Embedded Solutions Engineer (ESE)
• Technical Support

Customers should contact their distributor, representative or ESE for support. Local sales offices are also available to
help customers. A listing of sales offices and locations is included in this document.

Technical support is available through the website at: www.microchip.com/support

Microchip Devices Code Protection Feature
Note the following details of the code protection feature on Microchip products:

• Microchip products meet the specifications contained in their particular Microchip Data Sheet.
• Microchip believes that its family of products is secure when used in the intended manner, within operating

specifications, and under normal conditions.
• Microchip values and aggressively protects its intellectual property rights. Attempts to breach the code

protection features of Microchip product is strictly prohibited and may violate the Digital Millennium Copyright
Act.

• Neither Microchip nor any other semiconductor manufacturer can guarantee the security of its code. Code
protection does not mean that we are guaranteeing the product is “unbreakable”. Code protection is constantly
evolving. Microchip is committed to continuously improving the code protection features of our products.

Legal Notice
This publication and the information herein may be used only with Microchip products, including to design, test,
and integrate Microchip products with your application. Use of this information in any other manner violates these
terms. Information regarding device applications is provided only for your convenience and may be superseded
by updates. It is your responsibility to ensure that your application meets with your specifications. Contact your
local Microchip sales office for additional support or, obtain additional support at www.microchip.com/en-us/support/
design-help/client-support-services.
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Quality Management System
For information regarding Microchip’s Quality Management Systems, please visit www.microchip.com/quality.
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